<!DOCTYPE html>
<html lang="en" class="no-js">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">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</script>
<meta property="og:url" content="https://health.wusf.usf.edu/post/inmate-deaths-reported-eight-florida-prisons" />
<meta property="og:description" content="The Florida Department of Health on Wednesday said a dozen inmates died from complications of COVID-19 at eight prisons within the past week. Dade" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Inmate Deaths Reported At Eight Florida Prisons" />
<link href="//health.wusf.usf.edu/sites/healthnewsfl/files/202007/lowell_cx_institute_prison_google.jpg" rel="image_src" />
<meta property="og:image" content="https://health.wusf.usf.edu/sites/healthnewsfl/files/styles/medium/public/202007/lowell_cx_institute_prison_google.jpg" />
<meta property="og:image:height" content="545" />
<meta property="twitter:creator" content="@HealthNewsFL" />
<meta content="Inmate Deaths Reported At Eight Florida Prisons" about="/post/inmate-deaths-reported-eight-florida-prisons" property="dc:title" />
<meta property="twitter:site" content="@HealthNewsFL" />
<meta property="twitter:card" content="summary" />
<meta property="og:image:width" content="956" />
<meta name="description" content="The Florida Department of Health on Wednesday said a dozen inmates died from complications of COVID-19 at eight prisons within the past week. Dade" />
<meta name="datePublished" content="2020-07-30" />
<meta name="has_audio" content="0" />
<meta name="programs" content="none" />
<link rel="shortlink" href="/node/35376" />
<link rel="canonical" href="/post/inmate-deaths-reported-eight-florida-prisons" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="category" content="Health News Florida" />
<meta name="nid" content="35376" />
<meta name="wordCount" content="460" />
<meta name="story_id" content="897106115" />
<meta name="keywords" content="inmates, prisons, prisoners, COVID-19, Coronavirus, Florida Department of Corrections" />
<meta name="org_id" content="0" />
<meta name="author" content="News Service of Florida" />
<link rel="shortcut icon" href="/sites/all/themes/pilot/favicon.ico" type="image/vnd.microsoft.icon" />
    <title>Inmate Deaths Reported At Eight Florida Prisons | Health News Florida</title>
    <link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_F3uD-Lw23WII-5kzB2YaJJzgKLwXUiYy4xQSzQwFLk4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_ZFlaYqkiQzTmlBPX4mQeT33IFQX3nR-zpGlyqFhtTNM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_zvGfITuoG3fK_aSXcGzAx6ouMNLTjUVdaj32lyoB1d8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_n6CNhIjyFqK4hjkcC08_Tj4A7HNBoqHytYKVOu-8ZHQ.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
.header-region-outer{background-color:#ffffff;}.branding .tagline{color:#000;}.branding .listen-live-toggle > a,.branding .header-utility > a,.branding .header-utility > a.trigger-nav{color:#DEDEDE;}@media screen and (min-width:641px){.branding .trigger-nav{background:#777777;}}@media screen and (max-width:640px){.branding .header-utility > a.trigger-nav,.active-menu .branding .header-utility > a.trigger-nav{color:#777777;}}#listen-live .listen-live-toggle{background-color:#0A88BC;}#listen-live .listen-live-btn{background-color:transparent;color:#DEDEDE;}@media screen and (min-width:640px){#listen-live .listen-live-btn{background-color:#0A88BC;}}.branding .give{background:#A32B19;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Lato:300,700,700italic,900,italic,regular&amp;subset=latin" media="all" />
<link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_rNOa52ddHHo43vtbWFENyfaQHT1FaOvc10aWBF5kZ7w.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://health.wusf.usf.edu/sites/health.wusf.usf.edu/files/css/css_Xv3Pbhll0CnRvvOZVEWjBRPbKr0z_6rfBBPBi2Ij-Dk.css" media="all" />
    <script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_xSpMA4ArVcBKOZ43sPqNRk0gxQZdDVifw27pIUCzWU0.js"></script>
<script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_P9u0bgloveAIlc2kutVCUB_xMaRV3YHWhSVHD3IN5tM.js"></script>
<script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_f_6-OzlFXjayKlsU5sJKLwjz7LFQvdIZDm-Mt6jKwyM.js"></script>
<script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_O1jGKArkrxoKrM3JlJqpkR-NymsmH_BJnrh06AY-nkQ.js"></script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_0H8QQndjosty9qttukscwn4EtOu7qKYjqlZYZrpK87g.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src="//stream.publicbroadcasting.net/analytics/aabu.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="//health.wusf.usf.edu/sites/healthnewsfl/files/js/js_cIYXjjunbJ1tPZkNXDCKfbPnSikiTC7YAPSeGVIPweI.js"></script>
<script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width">
  </head>

  <body class="html not-front not-logged-in page-node page-node- page-node-35376 node-type-post fixed-header" >
    <header role="banner" class="header">
  <div class="skiptocontent"><a href="#main-content">skip to main content</a></div>
    <div class="region region-header">
    <div id="block-baby-bear-baby-bear-header" class="block block-baby-bear">

    
  <div class="content">
    
<div class="header-region-outer">
  <section class="header-region-inner row">
    <div class="branding large-12 columns">
      <div class="brand-inner-wrapper">
        <a href="http://www.healthnewsflorida.org" rel="home" class="logo" title="Health News Florida Home"><img typeof="foaf:Image" src="//health.wusf.usf.edu/sites/healthnewsfl/files/202005/hnf_website_without_logos_wt_bgtm.png" alt="Health News Florida logo" title="Health News Florida Home" /></a>         <div class="tagline">
                  </div>
      </div>
      <div class="header-utility">
        <a class="trigger-nav" href="#">
          <span class="icon-list"></span>
          <span class="menu-text">Site Menu</span>
        </a>
        <a class="give" href="https://bit.ly/2mZzGf5" target="_blank">
  Donate</a>
      </div>
    </div>
  </section>
</div>
  </div>
</div>
  </div>
</header>
    <div class="nav-wrapper mobile">
      <nav>
        <div class="top-bar contain-to-grid" data-topbar>
          <ul class="title-area">
            <li class="toggle-topbar menu-icon">
              <a href="#">Menu</a>
            </li>
          </ul>
          <section class="top-bar-section">
            <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="http://wusf.usf.edu">WUSF Home</a>
</li>
<li>
<a href="http://www.wusfnews.org">WUSF News</a>
</li>
<li class="dd has-dropdown not-click">
<a href="http://health.wusf.usf.edu/">Special Coverage</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/2020-Florida-Legislature">2020 Florida Legislature</a>
</li>
<li class="left">
<a href="/term/coronavirus">Coronavirus</a>
</li>
<li class="left">
<a href="/term/parkland-shooting">Parkland shooting</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/their-only-option#stream/0">Their Only Option: Free Clinics</a>
</li>
<li class="left">
<a href="/term/obamacare">Health Care Reform</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/term/zika">Zika Virus</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/term/pregnant-and-poor#stream/0">Pregnant and Poor</a>
</li>
</ul>
</li>
<li>
<a href="/term/coronavirus">Coronavirus</a>
</li>
<li>
<a href="/term/npr-health">NPR Health</a>
</li>
<li>
<a href="/people/capacity/staff">News Staff</a>
</li>
<li>
<a href="/search/google">Search</a>
</li>
</ul>
</div>
          </section>
        </div>
      </nav>
    </div>
      <div class="region region-persistent">
    <div id="block-audity-audity" class="block block-audity">

    
  <div class="content">
      </div>
</div>
  </div>
    <div id="page-wrapper">
            <div id="page-document" role="document" class="page">
  <div class="nav-wrapper">
    <nav>
      <div class="top-bar contain-to-grid" data-topbar>
        <ul class="title-area">
          <li class="toggle-topbar menu-icon">
            <a href="#">Menu</a>
          </li>
        </ul>
        <section class="top-bar-section">
          <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="http://wusf.usf.edu">WUSF Home</a>
</li>
<li>
<a href="http://www.wusfnews.org">WUSF News</a>
</li>
<li class="dd has-dropdown not-click">
<a href="http://health.wusf.usf.edu/">Special Coverage</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/2020-Florida-Legislature">2020 Florida Legislature</a>
</li>
<li class="left">
<a href="/term/coronavirus">Coronavirus</a>
</li>
<li class="left">
<a href="/term/parkland-shooting">Parkland shooting</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/their-only-option#stream/0">Their Only Option: Free Clinics</a>
</li>
<li class="left">
<a href="/term/obamacare">Health Care Reform</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/term/zika">Zika Virus</a>
</li>
<li class="left">
<a href="http://health.wusf.usf.edu/term/pregnant-and-poor#stream/0">Pregnant and Poor</a>
</li>
</ul>
</li>
<li>
<a href="/term/coronavirus">Coronavirus</a>
</li>
<li>
<a href="/term/npr-health">NPR Health</a>
</li>
<li>
<a href="/people/capacity/staff">News Staff</a>
</li>
<li>
<a href="/search/google">Search</a>
</li>
</ul>
</div>
        </section>
      </div>
    </nav>
  </div>

  <div id="player" class="player">
      </div>

  
  
  
  
  <div class="row">
    <main id="content" role="main" class="main-content small-12 columns">
      <article class="story">
        <a id="main-content"></a>
        
                                    
        
        
        
        
        
        
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-35376" class="node node-post node-promoted full row" about="/post/inmate-deaths-reported-eight-florida-prisons" typeof="sioc:Item foaf:Document">
  <div class="small-12 columns">
        
    
    <h1 itemprop="name" class="post-title">
      Inmate Deaths Reported At Eight Florida Prisons    </h1>

  	
    
          <div class="by-date">
        <span class="submitted"><span property="dc:date dc:created" content="2020-07-30T08:50:43-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/news-service-florida" rel="author">News Service of Florida</a></span></span></span>
        <i class="bullet">&#8226;</i>
        <span class="pub-date">35 minutes ago</span>
      </div>
    
    <div class="row">
      <div class="large-2 columns sharing-and-programs">
        
        <div class="social-share clearfix"><a href="http://twitter.com/intent/tweet?url=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons&amp;text=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons&amp;t=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons&amp;body=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons" class="social-share-item email" title="Email" target="_blank">Email</a></div>      </div>

      <div class="medium-10 medium-pull-1 large-8 large-pull-2 columns post-body-container" >
        <div class="post-body">
          <div class="field field-name-field-image-gallery field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><ul class="gallery no-bullet"><li>
  <figure>
    <a title="At Lowell Correctional Institute, a women's facility near Ocala, at least 444 inmates have tested positive. " href="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/x_large/public/202007/lowell_cx_institute_prison_google.jpg" class="noexit lightbox">
      <img src="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/medium/public/202007/lowell_cx_institute_prison_google.jpg"  alt="Lowell Correctional Institute sign outside facility">
          </a>
    <div class="image-meta">
  <figcaption>
    <div class="caption">At Lowell Correctional Institute, a women's facility near Ocala, at least 444 inmates have tested positive. </div>
    <div class="attribution">
  <span class="credit">Google Maps </span>
    <span class="agency"></span>
</div>
  </figcaption>
</div>
  </figure>
</li>
</ul></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>The Florida Department of Health on Wednesday said a dozen inmates died from complications of COVID-19 at eight prisons within the past week. </p> <p>Dade Correctional Institution, Everglades Correctional Institution, Lowell Correctional Institution and South Florida Reception Center each had two inmates die after testing positive for the disease. Columbia Correctional Institution, Florida Women’s Reception Center, Graceville Correctional Institution and Wakulla Correctional Institution each had an inmate death. </p> <p><!--break--></p> <p>The Department of Corrections had earlier reported that the 12 inmates had died but had not released the names of the facilities where they were housed. </p> <p>A total of 46 inmates have died from complications of the disease, but no Department of Corrections employees have died, according to the state. Two employees of contractors who work with the Department of Corrections have died after contracting the virus, department spokeswoman Michelle Glady confirmed July 1. </p> <p>July has proven to be the deadliest month in Florida’s prison system since the start of the pandemic, with 22 inmates dying. As of mid-Wednesday, a total of 9,155 prisoners and corrections workers had tested positive for the disease, a jump from 8,432 cases reported on Tuesday. That total included 7,592 inmates.</p> <p>Santa Rosa Correctional Institution and Lowell Correctional Institution saw their caseloads increase by more than 100 overnight. Santa Rosa had 700 inmate cases and Lowell had 629 inmate cases as of Wednesday. Columbia Correctional Institution has the most cases, with 1,258 inmates known to have been infected as of Wednesday. </p> <p>Lowell, located north of Ocala, is the largest women’s prison in the state with 2,200 inmates. At least 444 of them – along with 20 staff members – have tested positive for the coronavirus. At nearby Florida Women’s Reception Center, 183 inmates have tested positive, plus 22 employees.</p> <p>Kim Lawrence communicates often with her daughter at the Women’s Reception Center. Her daughter told her that a 32-year-old former dorm mate died, but she didn’t know the cause of death. </p> <p>“So they’re freaking out. You know, I mean, it’s now you’re not just getting a cough and a cold. Some people, they’re realizing, are dying,” she told WMFE. </p> <p>Corrections Secretary Mark Inch on Wednesday touted the care provided to the inmates at Columbia Correctional, which is near Lake City. </p> <p>“The great majority of inmates at Columbia CI who have tested positive are showing mild or no symptoms of the virus," Inch said. "For those that do require an elevated level of medical care, our health care professionals continue to go above and beyond to provide outstanding medical attention.”</p> <p><em>Information from WMFE was used in this report. </em></p>  </div></div></div><div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/term/inmates" typeof="skos:Concept" property="rdfs:label skos:prefLabel">inmates</a></div><div class="field-item odd"><a href="/term/prisons" typeof="skos:Concept" property="rdfs:label skos:prefLabel">prisons</a></div><div class="field-item even"><a href="/term/prisoners" typeof="skos:Concept" property="rdfs:label skos:prefLabel">prisoners</a></div><div class="field-item odd"><a href="/term/covid-19" typeof="skos:Concept" property="rdfs:label skos:prefLabel">COVID-19</a></div><div class="field-item even"><a href="/term/coronavirus" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Coronavirus</a></div><div class="field-item odd"><a href="/term/florida-department-corrections" typeof="skos:Concept" property="rdfs:label skos:prefLabel">Florida Department of Corrections</a></div></div></div><div class="social-share bottom"><a href="http://twitter.com/intent/tweet?url=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons&amp;text=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons&amp;t=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Inmate%20Deaths%20Reported%20At%20Eight%20Florida%20Prisons&amp;body=https%3A%2F%2Fhealth.wusf.usf.edu%2Fpost%2Finmate-deaths-reported-eight-florida-prisons" class="social-share-item email" title="Email" target="_blank">Email</a></div>        </div>

        <div class="related">
          <div class="field-name-field-related-posts"><h3>Related Content</h3>
<div id="node-35198" class="node-teaser node node-post node-promoted npr_river_card row" about="/post/surge-florida-inmate-covid-19-cases-spurs-calls-help" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/surge-florida-inmate-covid-19-cases-spurs-calls-help"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/surge-florida-inmate-covid-19-cases-spurs-calls-help">Surge In Florida Inmate COVID-19 Cases Spurs Calls For Help</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2020-07-23T09:03:43-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name">Ana Ceballos / News Service of Florida</span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Jul 23,  2020 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="iStock" href="/post/surge-florida-inmate-covid-19-cases-spurs-calls-help" class="noexit">
    <img class="multiple" src="https://health.wusf.usf.edu/sites/healthnewsfl/files/styles/medium/public/202007/jailcell3_iStock_032320.jpg" alt="prison bars">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          iStock        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>Inside a sweltering prison in rural North Florida, the mass testing of hundreds of inmates began nearly two weeks ago on a Saturday, as corrections workers tried to sort and quarantine prisoners with symptoms of COVID-19.</p> <p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-35108" class="node-teaser node node-post node-promoted npr_river_card row" about="/post/cases-top-1000-among-florida-corrections-workers" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/cases-top-1000-among-florida-corrections-workers"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/cases-top-1000-among-florida-corrections-workers"> Cases Top 1,000 Among Florida Corrections Workers</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2020-07-20T08:15:33-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/news-service-florida" rel="author">News Service of Florida</a></span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Jul 20,  2020 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="iStock" href="/post/cases-top-1000-among-florida-corrections-workers" class="noexit">
    <img class="multiple" src="https://health.wusf.usf.edu/sites/healthnewsfl/files/styles/medium/public/202005/jailcell3_iStock_032320.jpg" alt="jail bars in a hallway at a prison">
          </a>

        <div class="image-meta">
      <figcaption>
        <div class="credit">
          iStock        </div>
      </figcaption>
    </div>
      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>The number of Florida corrections workers who have tested positive for COVID-19 surpassed 1,000 on Friday, according to the state Department of Corrections. </p> <p></p></div></div></div>    </div>

      </div>
</div>

<div id="node-35105" class="node-teaser node node-post npr_river_card row" about="/post/covid-19-stalks-florida-inmates-so-does-another-killer" typeof="sioc:Item foaf:Document">
  <div class="large-12 columns">
    <a class="mobile-teaser-link" href="/post/covid-19-stalks-florida-inmates-so-does-another-killer"></a>
    <div class='title-info'>
      <h2  property="dc:title" datatype="" itemprop="name"><a href="/post/covid-19-stalks-florida-inmates-so-does-another-killer">As COVID-19 Stalks Florida Inmates, So Does Another Killer</a></h2>
              <div class="by-date">
          <span class="submitted"><span property="dc:date dc:created" content="2020-07-20T07:41:03-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name">editor</span></span></span>
          <i class="bullet">&#8226;</i>
          <span class="pub-date">Jul 20,  2020 </span>
        </div>
          </div>

    <div class="content">
      
<div class="card-image-container">
  <figure>
    <a title="" href="/post/covid-19-stalks-florida-inmates-so-does-another-killer" class="noexit">
    <img class="multiple" src="https://mediad.publicbroadcasting.net/p/shared/npr/styles/medium/nprshared/202007/893050658.jpg" >
          </a>

      </figure>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><p>“They are dying in the heat,” said the distraught mother of an inmate at Dade Correctional Institution in Miami. “What have we done to deserve this. … How is it possible, knowing how hot it is here?”<br /></p></div></div></div>    </div>

      </div>
</div>
</div>        </div>
      </div>
    </div>
      </div>
</div>
  </div>
</div>
  </div>
              </article>
    </main>
  </div>

      <section class="post-content">
      <div>
          <div class="region region-post-content">
    <div id="block-pi-responsive-ads-mobile-1" class="block block-pi-responsive-ads">

    
  <div class="content">
      </div>
</div>
  </div>
      </div>
    </section>
  
  <div class="bottom-ads">
    <div class="bottom-ads-inner"></div>
  </div>
</div>

<footer class="footer" role="contentinfo">
  <div class="row">
    <div class="footer-affiliate-container small-centered columns">
                  <div class="region region-footer">
    <div id="block-pi-table-queue-partnerfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-partnerfooter">
  <p class="partnerslabel">
  Health News Florida Partners</p>
<div class="item-list"><ul class="partner-logos"><li class="first"><a href="http://wlrn.org/" target="_blank"><img typeof="foaf:Image" src="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/partner_footer_logo/public/201508/WLRN_Logo_130w.jpg" alt="WLRN Public Media" title="WLRN Public Media" /></a></li>
<li><a href="http://www.wmfe.org/" target="_blank"><img typeof="foaf:Image" src="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/partner_footer_logo/public/201508/907LOGO_Web_Sml.jpg" alt="WMFE Public Radio of Central Florida" title="WMFE Public Radio of Central Florida" /></a></li>
<li><a href="http://www.wusf.usf.edu" target="_blank"><img typeof="foaf:Image" src="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/partner_footer_logo/public/201508/WUSFPM_Horiz_meWt_72ppi_200W_WHT_ret.png" alt="WUSF Public Media" title="WUSF Public Media" /></a></li>
<li class="last"><a href="http://www.wusfnews.org" target="_blank"><img typeof="foaf:Image" src="//health.wusf.usf.edu/sites/healthnewsfl/files/styles/partner_footer_logo/public/201508/WUSF_News.png" alt="WUSF News" title="WUSF News" /></a></li>
</ul></div></div>
  </div>
</div>
<div id="block-pi-table-queue-auxiliarylinksfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-auxiliarylinksfooter">
  <div class="item-list"><ul class="auxiliary-links"><li class="first last"><span>&copy; 2020 Health News Florida</span></li>
</ul></div></div>
  </div>
</div>
  </div>
          </div>
  </div>
</footer>
      <script type="text/javascript">
<!--//--><![CDATA[//><!--
 (function ($) { $(document).foundation({ topbar: { custom_back_text: true, back_text: 'back', mobile_show_parent_link: true } }); }(jQuery));
//--><!]]>
</script>
    </div>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"15ba4da3e8","applicationID":"1108724","transactionName":"NlMBMhAECEZRAU1eDg8ZIgUWDAlbHwxWUwQ+RgIBBzoQXFUV","queueTime":0,"applicationTime":545,"atts":"GhQCRFgeG0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
